You have no items in your shopping cart.

Monday, June 17, 2019 4:05:37 AM

Bugs

Avatar

Posted: 5 years ago

#112 Quote

Support

Posted: 5 years ago

#112 Quote
Topic for reporting any problems and Bugs.

IMPORTANT NOTE: There is a known issues with installing new plugins in nopCommerce.
Please read this post for more information.

Posted: 4 years ago

#232 Quote
Hello-

I just updated from 3.3 to 3.4 and have a problem with the Smart Campaigns plugin:

/Admin/SmartCampaign/List  - throws error in nop log:

The 'StoreId' property on 'SmartCampaign' could not be set to a 'System.Boolean' value. You must set this property to a non-null value of type 'System.Int32'.
The details for the log entry.Full message:  System.InvalidOperationException: The 'StoreId' property on 'SmartCampaign' could not be set to a 'System.Boolean' value. You must set this property to a non-null value of type 'System.Int32'. at System.Data.Entity.Core.Common.Internal.Materialization.Shaper.ErrorHandlingValueReader`1.GetValue(DbDataReader reader, Int32 ordinal) at System.Data.Entity.Core.Common.Internal.Materialization.Shaper.GetPropertyValueWithErrorHandling[TProperty](Int32 ordinal, String propertyName, String typeName) at lambda_method(Closure , Shaper ) at System.Data.Entity.Core.Common.Internal.Materialization.Shaper.HandleEntityAppendOnly[TEntity](Func`2 constructEntityDelegate, EntityKey entityKey, EntitySet entitySet) at lambda_method(Closure , Shaper ) at System.Data.Entity.Core.Common.Internal.Materialization.Coordinator`1.ReadNextElement(Shaper shaper) at System.Data.Entity.Core.Common.Internal.Materialization.Shaper`1.SimpleEnumerator.MoveNext() at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection) at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source) at Nop.Core.PagedList`1..ctor(IQueryable`1 source, In..............

Can you help?

Thanks,
Steve
Avatar

Posted: 4 years ago

#234 Quote

Support

Posted: 4 years ago

#234 Quote
I can't repeat your problem...

Replace all files from the plugin folder and restart your site.
Plugin will upgrade itself.
We have added new functionality, you can separate the customers of each store.

You can try to upgrade plugin manually.

Run SQL script Update106.SmartCampaign.sql
and then run SqlServer.SmartCampaign.sql.

Can you write full error message?

Posted: 4 years ago

#235 Quote
I already tried that...both SQL scripts executed successfully. Still have same error.

Based on error, I think maybe in the FNS campaigns table, the storeID column is empty/null in the record. I will try putting a 1 into that field and see if it solves my problem.

Thanks,
Steve
Avatar

Posted: 4 years ago

#236 Quote

Support

Posted: 4 years ago

#236 Quote
It's strange.

Code from Update106.SmartCampaign.sql

update FNS_SmartCampaignBlackList
set StoreId=S.Id
from FNS_SmartCampaignBlackList F,(select top 1 Id from Store S order by S.DisplayOrder) S
Go
update FNS_SmartCampaign
set StoreId=S.Id
from FNS_SmartCampaign F,(select top 1 Id from Store S order by S.DisplayOrder) S
Go


had to change StoreId field.

This is not a problem, it is good that it works for you.

Posted: 4 years ago

#241 Quote
I logged onto server tonight and looked at the data in  the FNS_SmartCampaigns table.
There was only one campaign, and no NULL values in any column, so setting the StoreId column to True

I executed both scripts again tonight, but there was still no change.

I added a new campaign from the admin area, and when saving, got the generic page error and nothing in log.
But...when I look in the table using SSMS, I see the new record.
I then try to load smartcampaigns list in admin area and same error as before:

The 'StoreId' property on 'SmartCampaign' could not be set to a 'System.Boolean' value. You must set this property to a non-null value of type 'System.Int32'.


Not sure what to try....
Avatar

Posted: 4 years ago

#242 Quote

Support

Posted: 4 years ago

#242 Quote
I have found a bug in upgrade SQL script.
Download new version http://www.foxnetsoft.com/content/files/FoxNetSoft.SmartCampaigns.zip
and replace all files in plugin folder. Restart your site.
Thank you.



Posted: 4 years ago

#243 Quote
OK, problem solved.

Thank you!
Steve

Posted: 3 years ago

#1622 Quote
Hello-

I just installed the updated plugin (Version 2.02), and have tried adding this token to my Automatic email after purchase campaign:

%SmartCampaign.Product(s)%

I expected to see a list of all products in the customer's order with links to those products, but it does not appear anywhere on the messages.

Am I doing something wrong, or does it just not work with this type of campaign?
Avatar

Posted: 3 years ago

#1623 Quote

Support

Posted: 3 years ago

#1623 Quote
I'll add new token for products from order.
%Order.Product(s)%

Posted: 3 years ago

#1624 Quote
Oh, ok, now I understand...%SmartCampaign.Products(s)%  is just for products selected from Products tab.
Thank you, this will be very helpful for asking customers to return to review the products they purchased.

It is maybe also a good idea to have a separate template for %Order.Products% token so it is possible to change URL.
For example, I would want the links for each product in the order to go directly to the product reviews page, like this:
Hallux Trainer Insoles

Posted: 3 years ago

#1625 Quote
steveembry66@gmail.com wrote:

It is maybe also a good idea to have a separate template for %Order.Products% token so it is possible to change URL.

To clarify, I just mean have a different template, identical to ProductListTemplate.cshtml for the new token. I can change link myself.



Avatar

Posted: 3 years ago

#1626 Quote

Support

Posted: 3 years ago

#1626 Quote
I added support all order's token.
I added support custom token for products from the order.
Template file OrderProductTemplate.cshtml.
Token %SmartCampaignOrder.Product(s)%.

version 2.04

Posted: 3 years ago

#1634 Quote
Support wrote:
I added support all order's token.
I added support custom token for products from the order.
Template file OrderProductTemplate.cshtml.
Token %SmartCampaignOrder.Product(s)%.

version 2.04


Hello again-

I thought I understood how this new token is working, but now I realize I did not. My campaign is set to be sent 21 days after order date. I updated my plugin and changed my message template to use the new  %SmartCampaignOrder.Product(s)% token and waited 21 days, but then I learned that the messages did not display any of the products purchased....

So, last night I changed to the other new token %Order.Product(s)% but when I look in message queue at new messages being  generated, I can now see the products are displayed in message, but they do not include links to the product pages....

When I look at the code in OrderProductTemplate.cshtml, I see it is the template I want to be used...(has product name linked to product page). What token must I specify to cause this template to be used?




Avatar

Posted: 3 years ago

#1635 Quote

Support

Posted: 3 years ago

#1635 Quote
%SmartCampaignOrder.Product(s)%
Read all products from the order. Use only for SmartCampaign with type Automatic e-mails after purchase.
Ahter it  plugin generates html code using this file
~/Plugins/FoxNetSoft.SmartCampaigns/Views/SmartCampaign/OrderProductTemplate.cshtml
This template has url for each product from the order.

%Order.Product(s)%
Read all products from order for SmartCampaign with all types.
This is standard NopCommerce token.
This template is without urls for products.

I can change logic if you have another good idea.
  

Posted: 3 years ago

#1636 Quote
Support wrote:
%SmartCampaignOrder.Product(s)%
Read all products from the order. Use only for SmartCampaign with type Automatic e-mails after purchase.
Ahter it  plugin generates html code using this file
~/Plugins/FoxNetSoft.SmartCampaigns/Views/SmartCampaign/OrderProductTemplate.cshtml
This template has url for each product from the order.

%Order.Product(s)%
Read all products from order for SmartCampaign with all types.
This is standard NopCommerce token.
This template is without urls for products.

I can change logic if you have another good idea.
  


OK...that is what I thought...
I think there must be a problem because I did use the %SmartCampaignOrder.Product(s)% token, with type "Automatic emails after purchase", but when I looked through the message queue at the generated messages, I can see that no products appear in any of the message bodies...???

I see you have another update to this plugin available now...maybe if I update my plugin to newest version it will work correctly. I'll try and let you know-

Thanks,
Steve
Avatar

Posted: 3 years ago

#1637 Quote

Support

Posted: 3 years ago

#1637 Quote
Ok, I'll be wait.

Posted: 3 years ago

#1638 Quote
steveembry66@gmail.com wrote:


I see you have another update to this plugin available now...maybe if I update my plugin to newest version it will work correctly. I'll try and let you know-

Thanks,
Steve


I installed the newest update and when I use the %SmartCampaignOrder.Product(s)% token, still no products appear in the message bodies.

What can I do?
Avatar

Posted: 3 years ago

#1641 Quote

Support

Posted: 3 years ago

#1641 Quote
I don't know...
Can you download new release from our site? and replace plugin again. I don't found error but rewrite logic. It will help me find the problem in future.

1. Create test SmartCampaign for Administrator role with 3 tokens
%SmartCampaign.Product(s)%,
%Order.Product(s)%
%SmartCampaignOrder.Product(s)%  

2. Set type Automatic e-mails after purchase
3. Set Send via: 1 minutes.
4. Add 2 test products.
5. Open your site as Administrator and buy product from the list.
6. Open Admin mode and change order payment type to Paid.
7. Open Schedule tasks and press manually task Smart Campaign

P.S.
I can call you by skype and we'll do it together.
Avatar

Posted: 3 years ago

#1642 Quote

asimkhan107

Posted: 3 years ago

#1642 Quote
Hi,

I recently uploaded my nopcommerce site over the hosting service provider a year ago. It worked perfectly, I was able to login with my administrator account and performed all tasks with ease.

Then a few months ago they company updated their servers and migrated my website to their new servers, we had to tweak and update the configuration settings of the site, then I tired to login with my administrator account, but I started receiving an error page.

I asked my hosting company what the problem is, they responded that it is nopcommerce issue and that the nopcommerce community can help.

Please help me with this issue, I am unable to do anything.

Regards,
Asim

Powered by nopCommerce

Copyright © 2019 FoxNetSoft. All rights reserved