You have no items in your shopping cart.

Wednesday, July 24, 2024 6:57:26 PM

Bugs

Posted: 4 years ago

#10186 Quote

Support

Posted: 4 years ago

#10186 Quote
Topic for reporting any problems and bugs.

IMPORTANT NOTE: There is a known issues with installing new plugins in nopCommerce.
Please read this post for more information.

Posted: 4 years ago

#11016 Quote

m.cattaneo

Posted: 4 years ago

#11016 Quote
PROBLEM: not import price (OverriddenPrice) in attribute combinations

Posted: 4 years ago

#11021 Quote

Support

Posted: 4 years ago

#11021 Quote
This issue had Import Manager.

Posted: 4 years ago

#11023 Quote

m.cattaneo

Posted: 4 years ago

#11023 Quote
I ask you a litte feature:

"Import Manager" imports the values ​​of the Overridden Price but have not a scheduler.
"Price Manager" does not have a scheduler.
"Automatic Updates" has the schedule, but does not allow updating the prices that belong to the product combinations(OverriddenPrice)

It is possible to add a scheduler to "Price Manager" or allow updating  Overridden Price in "Automatic Updates" ?
thanks

Posted: 4 years ago

#11024 Quote

Support

Posted: 4 years ago

#11024 Quote
I don't plan to add scheduler to Import Manager and Price Manager.

But I'll see how to update product combination price using this plugin "Automatic Updates".
Write me after two days.

Posted: 4 years ago

#11025 Quote

m.cattaneo

Posted: 4 years ago

#11025 Quote
Support wrote:
I don't plan to add scheduler to Import Manager and Price Manager.

But I'll see how to update product combination price using this plugin "Automatic Updates".
Write me after two days.


Hi, I write you to remember this post:
In PLUGIN: AUTOMATIC UPDATES It is possible to add import price (OverriddenPrice) in attribute combinations?
thanks

Posted: 4 years ago

#11026 Quote

Support

Posted: 4 years ago

#11026 Quote
I did the new release.
Download the new ZIP file and replace all files.
Restart your store.

Open plugin configure page (after it plugin will add new localized resources).

Add the new column OverwritenPrice.
Try and write me about result.

Posted: 8 months ago

#13599 Quote

JohnW

Posted: 8 months ago

#13599 Quote

I have a template
Column 0 -> Sku
Column 3 Stock Quantity

WORKS
Sku,IGNORE,IGNORE2,StockQuantity,IGNORE3
Test,Test,Test,"11",Test

FAILS - says file has no rows
Sku,IGNORE,IGNORE2,StockQuantity,IGNORE3
"Test",Test,Test,"11",Test

FAILS - says file has no rows
Sku,IGNORE,IGNORE2,StockQuantity,IGNORE3
Test,"Test",Test,"11",Test

I've tried setting Field Enclosure to " and to leaving it blank
I've tried setting up column mappings for columns I'm ignoring that didn't help

It fails if the SKU (Column0) has quotes
It fails if one of the Ignore columns has quotes

Apologies if I'm doing something silly


Posted: 8 months ago

#13600 Quote

Support

Posted: 8 months ago

#13600 Quote
"11"
Stock quantity has to have the integer format =11.
You can play with the enclosed mark (" or ') for the csv file.
But I advise using the TSV format (tab separated for such variants) or Excel.

If you have the CSV format you need to check the enclosed mark and the separator.
Please don't spend the time with " and '
You  need to create the new separator for your data, ex. tab or | .

Posted: 8 months ago

#13602 Quote

JohnW

Posted: 8 months ago

#13602 Quote
The "Field enclosure" doesn't seem to work very well with | or "

I'm reliant on an automated export from a legacy system that uses " as an enclosure for all columns. It also puts the quantity in as a decimal in quotes

Sku,IGNORE,IGNORE2,StockQuantity,IGNORE3
"SKUXXX","Test","Test","13.000","Test"

But I can't even get "simpler" versions to work e.g.

Sku,IGNORE,IGNORE2,StockQuantity,IGNORE3
"SKUXXX","Test","Test",13,"Test"

Posted: 8 months ago

#13603 Quote

Support

Posted: 8 months ago

#13603 Quote
Upgrade the plugin. I fix this bug.
Overwrite the plugin with new  files and restrat nopcommerce.
>"SKUXXX","Test","Test","13","Test"
You need to use the enclosed character """  and delimeter ",".
use the next lines
"SKUXXX","Test","Test","13","Test" this line is correct
or
"SKUXXX","Test","Test",13,"Test" - this is correct too




Posted: 8 months ago

#13605 Quote

JohnW

Posted: 8 months ago

#13605 Quote
I confirm the following now works correctly following the update

Sku,IGNORE,IGNORE2,StockQuantity,IGNORE3
"SKUTEST","Test","Test","15.0","Test"

Posted: 8 months ago

#13607 Quote

Support

Posted: 8 months ago

#13607 Quote
Thank you for your help in solving this bug.

Powered by nopCommerce

Copyright © 2023 FoxNetSoft. All rights reserved