You have no items in your shopping cart.

Monday, November 18, 2019 10:35:50 AM

Bug with php Urls

Avatar

Posted: one year ago

#8205 Quote

ActionWebsites

Posted: one year ago

#8205 Quote
I have added a number of URL redirects and none are working, still get page not found.

I use such URLs
card.php?type=123456
card.php?type=123457
Avatar

Posted: one year ago

#8206 Quote

Support

Posted: one year ago

#8206 Quote
I added support query string in release 1.02.
Nop 4.00 allows redirect .php urls from the box, but nop 3.90 doesn't allow it.

Instruction for nop 3.90.
1. Install UrlRewrite
https://www.iis.net/downloads/microsoft/url-rewrite
2. Add this rule in web.config

            <rules>
                <rule name="PHPToASPNET" stopProcessing="true">
    <match url="card.php[/]?$" />
                    <action type="Redirect" url="cardphp" appendQueryString="true"  redirectType="Permanent" />
                </rule>
            </rules>


Example of all block


3. You want to redirect this old URL
card.php?type=123456

UrlRewrite will redirect this URL card.php?type=123456 to new Url cardphp?type=123456

Add this URL (without dot) in the list of RedirectManager


Avatar

Posted: one year ago

#8207 Quote

ActionWebsites

Posted: one year ago

#8207 Quote
Thank you for actioning so quick, the updated version, web.config changes and notes have enabled PHP paramterised redirects to work just fine now.

Also please note in your fix post above I needed to edit all instances of card.php to cart.php. Small typo but the correct fix in the end. Thank you for being so fast in updating and fixing, most appreciated.
Avatar

Posted: one year ago

#8208 Quote

Support

Posted: one year ago

#8208 Quote
Thank you.

Powered by nopCommerce

Copyright © 2019 FoxNetSoft. All rights reserved