You have no items in your shopping cart.

Tuesday, April 20, 2021 7:14:17 AM

Error on nopcommerce 3.5

Avatar

Posted: 4 years ago

#2970 Quote

dkhoviv@icloud.com

Posted: 4 years ago

#2970 Quote
I am trying to use nopPagespeedTools plugin for 3.5, but as far as switch on any of oprimization options, site go down and log show
016.12.02 02:27:54:6915*******
Optimization. url=/en/
    hreflang start
    CSS start
    JS start
    WebMarkupMin start
Optimization(Html) url=/en/
    Error: Line 6, Column 158: During parsing of HTML-code error has occurred.
Original size: 14,957 byte(s)
New size: 0 byte(s)
You saved: 0.00%

End (duration=00:00:00.0311586)
Avatar

Posted: 4 years ago

#2971 Quote

Support

Posted: 4 years ago

#2971 Quote
>site go down and log show.
Couldn't you open the page? If plugin can't minify the page, plugin must return original page....
Can you disable plugin and send me URL for this page or original html page as a file.
I want to check your page.

Avatar

Posted: 4 years ago

#2972 Quote

dkhoviv@icloud.com

Posted: 4 years ago

#2972 Quote
Nop, page is giving error
site is www.ecoagua.net
Avatar

Posted: 4 years ago

#2973 Quote

dkhoviv@icloud.com

Posted: 4 years ago

#2973 Quote
The issue is that if ANY optimization option is on, site goes down  (((
Avatar

Posted: 4 years ago

#2974 Quote

Support

Posted: 4 years ago

#2974 Quote
1. Can you disable plugin on your site?
2. Send me your Nop log.
3. Do you have another plugin with this .dll file WebMarkupMin.Core.dll?
Avatar

Posted: 4 years ago

#2981 Quote

Mishiwaka

Posted: 4 years ago

#2981 Quote
Support wrote:
1. Can you disable plugin on your site?
2. Send me your Nop log.
3. Do you have another plugin with this .dll file WebMarkupMin.Core.dll?

1. It's disabled and unistalled now
2. Where I suppose to have it?
3. Which plugins it would be?
Avatar

Posted: 4 years ago

#2985 Quote

Support

Posted: 4 years ago

#2985 Quote
>2. Where I suppose to have it?
Open NopCommerce in admin mode and select item in menu 'System-Log'.

>3. Do you have another plugin with this .dll file WebMarkupMin.Core.dll?
You should try to find this file in another plugin folders. Try to find this plugin in all site folder too.
I think you have another plugin with this .dll file... But another file has another version.

Do you use original NopCommerce kernel .dll files?


Avatar

Posted: 4 years ago

#2998 Quote

Mishiwaka

Posted: 4 years ago

#2998 Quote
Log looks like this, when I'd try to start html minifying

Error  Optimization(Html). Error. url=/en/, Line 5, Column 91: During parsing of HTML-code error has occurred.  12/16/2016 8:16:53 AM  View
  Error  Optimization(Html). Error. url=/en/, Line 5, Column 91: During parsing of HTML-code error has occurred.  12/16/2016 8:16:49 AM  View
  Error  Optimization(Html). Error. url=/en/, Line 5, Column 91: During parsing of HTML-code error has occurred.  12/16/2016 8:16:45 AM  View
  Error  Optimization(Html). Error. url=/en/blog, Line 2, Column 74: During parsing of HTML-code error has occurred.  12/16/2016 8:16:45 AM  View
  Error  Optimization(Html). Error. url=/en/blog, Line 2, Column 74: During parsing of HTML-code error has occurred.  12/16/2016 8:16:38 AM  View
  Error  Optimization(Html). Error. url=/en/blog, Line 2, Column 74: During parsing of HTML-code error has occurred.  12/16/2016 8:16:37 AM  View

But site goes unreachable.

How to check?
Avatar

Posted: 4 years ago

#2999 Quote

Support

Posted: 4 years ago

#2999 Quote
Your HTML code has some problems.
I tried to validate your site using several validators and I saw errors. Remove errors. Google sees errors too :(.
Example.
https://html5.validator.nu/?doc=https%3A%2F%2Fwww.ecofilters.es%2Fen%2F

https://validator.w3.org/nu/?doc=https%3A%2F%2Fwww.ecofilters.es%2Fen%2F


But you are right.  Plugin had to leave original HTML page and saved the notification about problem in Nop log.
I'll try to reproduce this problem.
Avatar

Posted: 4 years ago

#3000 Quote

Support

Posted: 4 years ago

#3000 Quote
We have fixed this bug.

Version 1.05 - December 16h, 2016

- fixed bug 'crash site using broken HTML page'.

Download new version and try.

But you must remove all problems from your pages.

Thank you for you help with finding the problem.

Avatar

Posted: 4 years ago

#3031 Quote

Mishiwaka

Posted: 4 years ago

#3031 Quote
I've download a new version, it gives no error, but also looks like doing nothing for my web. Is it possible that 15 days already expired, or new version will count it from beginning?
Avatar

Posted: 4 years ago

#3032 Quote

Mishiwaka

Posted: 4 years ago

#3032 Quote
Oh, sorry, just forgot to switch it on ))) But ... it crash again anytime I use any option (((
Avatar

Posted: 4 years ago

#3033 Quote

Support

Posted: 4 years ago

#3033 Quote
Maybe IIS used old version from intenal .NET cache...

Open the file Global.asax in site root folder. Add spacebar to the end of the file, save it and try.
Write me about result.
If you see error again. Send me plugin Log file from App_Data folder.

Powered by nopCommerce

Copyright © 2019 FoxNetSoft. All rights reserved