You have no items in your shopping cart.

Profile: steveembry66@gmail.com

Avatar
Statistics

    steveembry66@gmail.com wrote:

    Hello again-

    I am trying to implement JqueryTools.org's tabs UI into my noparticles, and having some trouble with it.
    It appears that the call to the javascript function never executes, and I'm not quite sure how to get around the problem.

    There is a reference to the js file and 2 CSS files which I handled on the /plugins/foxnetsoft.articles/views/articleread/articlepost.cshtml:


        Html.AddScriptParts("~/Content/KnowledgebaseTabs/jquery.tools.min.js");
        @* Html.AddScriptParts("http://cdn.jquerytools.org/1.2.7/full/jquery.tools.min.js"); *@
        Html.AddCssFileParts(@Url.Content("~/Content/KnowledgebaseTabs/tabs.css"));    
        Html.AddCssFileParts(@Url.Content("~/Content/KnowledgebaseTabs/tabs-panes.css"));


    ...and a separate little javascript:

    <script>
    // perform JavaScript after the document is scriptable.
    $(function() {
        // setup ul.tabs to work as tabs for each div directly under div.panes
        $("ul.tabs").tabs("div.panes > div");
    });
    </script>


    The tabs render OK, so the paths to the CSS and js file are all good...it's just that the little script won't execute whether I include it at the bottom of the view, top of the view, or in the article content itself...

    Where should the little script be placed in order for it to execute? Maybe in the nopcommerce footer??

    You can see the tabs here:
    http://64.239.149.236/article/achilles-tendon-rupture-2
    ..and if you view the source, you will see the content that should be appearing if that javascript function call was working...

    Any help would be greatly appreciated!

    UPDATE:
    I ended up using a different Jquery tabs UI called Easy Responsive Tabs, and have no problems with it now.

    Thanks,
    Steve

    5 years ago

    Hello again-

    I am trying to implement JqueryTools.org's tabs UI into my noparticles, and having some trouble with it.
    It appears that the call to the javascript function never executes, and I'm not quite sure how to get around the problem.

    There is a reference to the js file and 2 CSS files which I handled on the /plugins/foxnetsoft.articles/views/articleread/articlepost.cshtml:


        Html.AddScriptParts("~/Content/KnowledgebaseTabs/jquery.tools.min.js");
        @* Html.AddScriptParts("http://cdn.jquerytools.org/1.2.7/full/jquery.tools.min.js"); *@
        Html.AddCssFileParts(@Url.Content("~/Content/KnowledgebaseTabs/tabs.css"));    
        Html.AddCssFileParts(@Url.Content("~/Content/KnowledgebaseTabs/tabs-panes.css"));


    ...and a separate little javascript:

    <script>
    // perform JavaScript after the document is scriptable.
    $(function() {
        // setup ul.tabs to work as tabs for each div directly under div.panes
        $("ul.tabs").tabs("div.panes > div");
    });
    </script>


    The tabs render OK, so the paths to the CSS and js file are all good...it's just that the little script won't execute whether I include it at the bottom of the view, top of the view, or in the article content itself...

    Where should the little script be placed in order for it to execute? Maybe in the nopcommerce footer??

    You can see the tabs here:
    http://64.239.149.236/article/achilles-tendon-rupture-2
    ..and if you view the source, you will see the content that should be appearing if that javascript function call was working...

    Any help would be greatly appreciated!

    Thanks,
    Steve

    6 years ago
    Bugs

    Awesome, thanks! The update makes it look perfect now.

    6 years ago
    Bugs

    Hello-

    I sent in a contact request last week, but have had no response.
    I am having issues with the styling of the nopArticles plugin.

    My nopCommerce site is version 3.10 and uses the nop-templates.com (7spikes) Alfresco Responsive theme.

    The issue can be seen here:
    http://64.239.149.236/articles/

    Notice how the images are displayed....ugly...


    When you mouse-over the product images, the brown square and text is supposed to move up and cover the product photo, like you see here:
    http://64.239.149.236/carbon-graphite-shoe-plate

    Can this be fixed?

    Thanks,
    Steve

    6 years ago

    Powered by nopCommerce

    Copyright © 2019 FoxNetSoft. All rights reserved